Skip to content

Instantly share code, notes, and snippets.

@garis
Last active February 20, 2022 14:20
Show Gist options
  • Save garis/e427d35be1ee4a6d693597e7ca436b73 to your computer and use it in GitHub Desktop.
Save garis/e427d35be1ee4a6d693597e7ca436b73 to your computer and use it in GitHub Desktop.
Fastweb IPv6 on Mikrotik
Take note of the IPv6 prefix assigned then disable IPv6 LAN in the Fastgate (Avanzate->then disable "IPV6 su LAN").
Commands:
/interface 6to4
add clamp-tcp-mss=yes comment="Fastweb IPv6 tunnel" disabled=no dont-fragment=no dscp=inherit !ipsec-secret !keepalive local-address=192.168.2.1 mtu=1480 name=FastwebIPv6Tunnel remote-address=81.208.50.214
/ipv6 address
add address=2001:b07:XXXX:YYYY::512/128 advertise=no disabled=no eui-64=no from-pool="" interface=FastwebIPv6Tunnel no-dad=no
add address=2001:b07:XXXX:YYYY::/64 advertise=yes disabled=no eui-64=no from-pool="" interface=bridge no-dad=no
/ipv6 nd
set [ find default=yes ] advertise-dns=yes advertise-mac-address=yes disabled=no hop-limit=unspecified interface=all managed-address-configuration=no mtu=unspecified other-configuration=yes ra-delay=3s ra-interval=3m20s-10m ra-lifetime=15m \
reachable-time=unspecified retransmit-interval=unspecified
/ipv6 nd prefix default
set autonomous=yes preferred-lifetime=1w valid-lifetime=4w2d
/ipv6 route
add !bgp-as-path !bgp-atomic-aggregate !bgp-communities !bgp-local-pref !bgp-med !bgp-origin !bgp-prepend !check-gateway disabled=no distance=1 dst-address=2000::/3 gateway=FastwebIPv6Tunnel !route-tag scope=30 target-scope=10
/ipv6 settings
set accept-redirects=yes-if-forwarding-disabled accept-router-advertisements=yes-if-forwarding-disabled forward=yes max-neighbor-entries=8192
Check also DNS servers and other stuff.
Note:
-) 192.168.2.1 is the LAN IP of the Mikrotik interface connected to the Fastgate, also in DMZ.
-) Use RouterOS stable (version 6.48.1 works). Beta 7.1beta5 can't maintain a stable IPv6 interface.
-) XXXX:YYYY needs to be changed to the prefix available in the Fastgate (Prefisso IPV6 (6RD)).
-) 512 in 2001:b07:XXXX:YYYY::512/64 is a random value.
-) 81.208.50.214 could change by geographic location.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment